تقييم الموضوع :
  • 0 أصوات - بمعدل 0
  • 1
  • 2
  • 3
  • 4
  • 5
[VB.NET] مشكلة اداة تم اضافتها الى com components
#1
السلام عليكم 

قمت بإضافة أداة الى قائمة com components ومن ثم استدعائها واضافتها للتول بوكس 
الى هنى كل شي ممتاز 
ولاكن المشكلة التي لم استطع حلها هي اني اريد تغيير مسار هذه الأداة ليتم استدعها من مسار البرنامج مباشرة
ولم ينجح الأمر معي 
حاولت أيضا حذف الأداة واعادتها لأجعلها في مسار C ولم يفلح ذالك معي فقد أصبحة الأداة موجودة ومسرها الإفتراضي سطح المكتب 
فعند نقلي للبرنامج الى جهاز آخر لم يعمل بسبب إختلاف مسار سطح المكتب في الجهازين وبذالك لم يجد الأداة ولم يعمل البرنامج 
بسبب اعتماده في العمل على الأداة 



فأرجو المساعدة في طريقة تغيير مسار الأداة إلى المسار الذي يتم تثبيت البرنامج به
أو على الأقل أقوم بتغيير مسار الإستدعاء الى c 
فقد حاولت استدعاها مرة أخرى من مسار c ولاكن لم يتغير المسار
وبقي كما هو



الرد
تم الشكر بواسطة: princelovelorn
#2
و ماذا لو تضعها في مجلّد ال Debug ؟؟
الرد
تم الشكر بواسطة: princelovelorn
#3
قمت بوضعها في عدة محاولات سابقة .. ولاكن لم تعمل ولم يتعرف عليها البرنامج الا على سطح المكتب .. وانا اريد تغيير ذالك المسار الى C مباشرة .. او الى مسار تثبيت البرنامج ..
أما في الوضع الحالي  عندما أضع الأداة على سطح المكتب تعمل .. وعندما احذها .. البرنامج لا يعمل نهائيا اريد طريقة لحذفها من قائمة com components او تعديل مسارها
الرد
تم الشكر بواسطة: princelovelorn
#4
تم تغيير المسار بنجاح .. الى C عن طريق الرجستري 

وعملة الأداة من المسار الجديد بنجاح على جهازي الذي يوجد عليه Visual Studio 2012 .. 

ولاكن المشكلة  الأساسية التي إعتقدت بأن تغيير مسار الأداة سيحلها لم تحل للأسف



وهي : عند نقل البرنامج لجهاز آخر لا يعمل .. قمت بسحب مفاتيح الرجستري المرتبطة ب الأداة من جاز البرمجة وادخلتها بالجهاز الجديد 

لعل الأمر يفلح .. ولاكن لا نتيجة فالمشكلة هي نفسها
الرد
تم الشكر بواسطة: princelovelorn
#5
(27-01-19, 04:33 PM)paypalet كتب :
تم تغيير المسار بنجاح .. الى C عن طريق الرجستري 

وعملة الأداة من المسار الجديد بنجاح على جهازي الذي يوجد عليه Visual Studio 2012 .. 

ولاكن المشكلة  الأساسية التي إعتقدت بأن تغيير مسار الأداة سيحلها لم تحل للأسف



وهي : عند نقل البرنامج لجهاز آخر لا يعمل .. قمت بسحب مفاتيح الرجستري المرتبطة ب الأداة من جاز البرمجة وادخلتها بالجهاز الجديد 

لعل الأمر يفلح .. ولاكن لا نتيجة فالمشكلة هي نفسها


تم حل المشكلة بعد عدة تجارب ... هههههههههههه أنا أسأل وأنا أجيب ... 
المشكلة كانت بسيطة ولاكني لم أنتبه ولم تخطر ببالي 

والحل تسجيل ملف dsoframer.ocx عبر نافذة الأوامر cmd ليتم إضافت القيم الخاصة بها إلى الرجستري
الرد
تم الشكر بواسطة: princelovelorn



التنقل السريع :


يقوم بقرائة الموضوع: بالاضافة الى ( 1 ) ضيف كريم