تقييم الموضوع :
  • 0 أصوات - بمعدل 0
  • 1
  • 2
  • 3
  • 4
  • 5
[نقاش] How to: Configure the .NET Framework 4 Runtime
#1
http://msdn.microsoft.com/en-us/library/....100).aspx
----------------------------------------------------------------------------
اخواني الاعزاء.
هل يعني هذا المقال (بالرابط) انه يمكن تشغيل برنامجي ذو framework 4 مثلا باكس بي بالتعديل المذكور لو افترضت امكانية هذا التعديل بالكود؟
ممكن ايضاح؟
بارك الله فيكم.
أستودعكم الله الذي لا تضيع ودائعه أرجو ان تجدوا بمشاركاتي ما يجعلكم تدعون لي بخير ان تحتم غيابي.
الرد }}}}
تم الشكر بواسطة:
#2
السلام عليكم ورحمة الله
قمت بعمل التعديلات بالشكل التالي
نسخ الكود داخل ملف xml وجعلت اسمه configuration ونقلته الي ويندوز اخر عليه NET Framework 3.5
ولم يعمل نسخت الكود داخل ملف الي اسمه WindowsApplication7.xml ايضا لم يعمل مش فاهم الشرح ده يقصدو بيه ايه
ياريت حد من الاخوة الكبار يبحث هذا الامر
وجزاكم الله خيرا
الرد }}}}
تم الشكر بواسطة: سعود
#3
السلام عليكم و رحمة الله و بركاته,

إقتباس :This topic describes how to configure your .NET Framework applications to run on the .NET Framework version 4 without recompiling them.

لم يذكروا إن كان يمكنك تشغيل البرامج على Windows XP, و إنما كانوا يشرحون عن كيفية إعداد برامج الـ NET Framework. لتشغيلها على NET Framework 4. بدون عمل Compile لهم.

إقتباس :
To run an application on the .NET Framework 4

:In the folder that contains the .exe file of your application, create an application configuration file with the following elements

كود :
<configuration>
   <startup>
      <supportedRuntime version="v4.0"/>
   </startup>
</configuration>

Run your application.

الشرح هنا يقول:

في الحافظة (Folder) التي تحتوي على ملف (exe.) من مشروعك, إعمل ملف (configuration) جديد و ضع فيه الكود المذكور أعلاه و من ثم شغل البرنامج.


أرجوا أن أكون أفدتك في المعلومة Smile



تحياتي
الرد }}}}
تم الشكر بواسطة: الشاكي لله , ali.alfoly , سعود
#4
اخي سعوود

اذا كنت تريد تشغيل برنامجك افتراضيا على xp + vista + seven (دون الحاجة لتركيب الفريم وورك)

عليك بكتابة برنامجك بواسطة freamwork 2.0

لان xp يحتوي على 2.0 افتراضيا

والseven يحتوي على 3.5 افتراضيا


وال3.5 يمكنه تشغيل البرامج التي على 2.0 و 3.0 و 3.5 (لأنها على CLR واحد)

لذلك لن تحتاج لأن تقول للعميل قم بتنصيب الفريم وررك 2.0 على وندوز 7 .

لأن كما قلنا ال7 يحتوي على 3.5 افتراضيا . وال3.5 يشغل الاصدارات القديمة (2.0 و3.0)

وبالتالي استغلينا نسخ الفريم وورك الافتراضية في كلا النظامين (او الثلاثة) ،


--

طبعا للاحد ياخذه مقياس ان اي برنامج مبرمج على اصدار قديم من الفريم وررك سيعمل على الحديث

مثلا لو صممت برنامج على 3.5 وجيت اشغله على جهاز عليه فريم وورك 4.0 فقط ..

لن يعمل البرنامج لأن 4.0 له CLR مختلف .


الاصدارات التي لها نفس الCLR :


--(CLR 1)
1.0
1.1

--(CLR 2)
2.0
3.0
3.5

--(CLR 4)
4.0
4.5
4.51


مثلا لو صممت برنامج على 1.0 وجيت اشغله على فريم وورك 1.1 سيعمل بكل سهولة

ولكن لو شغلته على فريم وورك 2.0 ، لن يعمل لان 2.0 ضمن CLR مختلف



واذا صممت برنامج على فريم وورك 4.0 وجيت شغلته على فريم وررك 4.51 ، سيعمل البرنامج -لانه ضمن نفس الCLR- .

--
--

المصدر
http://msdn.microsoft.com/en-us/library/bb822049.aspx

الرد }}}}
#5
السلام عليكم ورحمة الله
جزاكم الله خيرا اخواني وبارك فيكم
طيب سؤال لو انا عامل مشروع باصدار 2.0
اقدر اخد مكتبة معينة من 4.0 مثلا علي شكل ملف ديل واضيفها لمشروعي واشتغل بيها
الرد }}}}
تم الشكر بواسطة: سعود
#6
(04-11-13, 11:29 AM)ali.alfoly كتب : السلام عليكم ورحمة الله
جزاكم الله خيرا اخواني وبارك فيكم
طيب سؤال لو انا عامل مشروع باصدار 2.0
اقدر اخد مكتبة معينة من 4.0 مثلا علي شكل ملف ديل واضيفها لمشروعي واشتغل بيها

لا ماتقدر

-

اصلا انا مااشوفها مشكلة ابدا الفريم وورك

اي مستخدم حاب يستخدم برنامجك

راح ينزل اي اصدار تطلبه .. الفريم وورك حجمه لايتعدى 40 مب
الرد }}}}
تم الشكر بواسطة: ali.alfoly , سعود
#7
مرحبا اخي الشاكي لله

اخي شكرا لك على هذة المعلومات القيمة المستمدة من

المكتبة الام (( msdn.microsoft.com ))

لي رجاء منك اخي الشاكي لله
ياليت و اتمنى منكم ترجمة المقالة بنفس الاسلوب الذي تكلمت به
بشيء من التفصيل لو كان لديكم وقت فوالله هذا الموضوع مهم بالنسبة لنا كمبتدئين
في البرمجة


اكرر لك شكري اخي الشاكي لله
لا يلومني على انقطاعاتي المتكررة
فهي اما عمل او دراسة او تربية




سُبْحَانَكَ اللَّهُمَّ وَبِحَمْدِكَ، أَشُهَّدٌ أَنَّ لَا إلَهَ إلا أَنْتَ، أَسَتَغْفِرُكَ وَأَتُوبَ إِلَيْكَ
الرد }}}}
تم الشكر بواسطة: ali.alfoly , سعود
#8
(04-11-13, 12:18 PM)ابو ابراهيم كتب : مرحبا اخي الشاكي لله

اخي شكرا لك على هذة المعلومات القيمة المستمدة من

المكتبة الام (( msdn.microsoft.com ))

لي رجاء منك اخي الشاكي لله
ياليت و اتمنى منكم ترجمة المقالة بنفس الاسلوب الذي تكلمت به
بشيء من التفصيل لو كان لديكم وقت فوالله هذا الموضوع مهم بالنسبة لنا كمبتدئين
في البرمجة


اكرر لك شكري اخي الشاكي لله

العفو ...


لكن تبي الصراحة انا مشغول جداا

اولا علي وضع المقالة الرابعة في [سلسلة التحكم]

الي المفروض تكون جاهزة من الاسبوع الماضي

وثانيا اعمل على مشروع vb4arb chatting الي بيجهز قريبا (وهو مثال لكيفية الاستفادة من WebService)


عندنا 722 عضو في المنتدى اكيد واحد منهم يقدر يسوي مقالة !
الرد }}}}
تم الشكر بواسطة: ابو ابراهيم , سعود
#9
السلام عليكم ورحمة الله
حركة كنت تعلتمتها قديما من الاخ kslawy حفظه الله
http://msdn.microsoft.com/ar-sa/library/bb822049.aspx
وهي استبدال
en-us
بـ
ar-sa
ليتم عرض الصفحة باللغة العربية
لاكن ليس كل الصفحات يتم ترجمتها
ولحسن الحظ هذه الصفحة مترجمة
الحمد لله رب العالمين
الرد }}}}
تم الشكر بواسطة: الشاكي لله , ابو ابراهيم , سعود
#10
والله يا جماعة الخير .. هذا الموضوع المثار مهم جدا .. بس لي سؤالين
عملت برنامج ب 2010 وكان معاه ريبورت
اشتغل البرنامج عادي جدا على وندوز 7
ولما جيت اشغل الريبورتات فوجئت انه جايب رسالة مفادها
" الريبورتات المنشأة بواسطة 2010 لازم ينزلها فرام ورك 4 " ........... بغض النظر عن فرام البرنامج
===========================
هل كلام ده صحيح ؟
===============================================
سؤالي التاني وهو الاهم
انا بعمل ملف الحزيم ببرنامج Smart Install Maker هل من طريقة لادماجه وينزل مع البرنامج مرة واحدة ؟
الرد }}}}
تم الشكر بواسطة: سعود


المواضيع المحتمل أن تكون متشابهة .
الموضوع : الكاتب الردود : المشاهدات : آخر رد
  [سؤال] مشكلة في تنزيل net framework 4.6 المبرمج العبقري 4 244 08-04-16, 05:30 PM
آخر رد: المبرمج العبقري
Exclamation [VB.NET] سؤال بخصوص NET Framework 2 Profeassional VB.NET 1 248 14-07-15, 11:04 PM
آخر رد: ابو ابراهيم
  [سؤال] هل يمكن دمج net framework. مع ملف exe لبرنامج مصنوع بالفيجوال بيسك mohamed haroon 0 365 04-07-15, 10:18 AM
آخر رد: mohamed haroon

التنقل السريع :


يقوم بقرائة الموضوع: بالاضافة الى ( 1 ) ضيف كريم